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‘Introduction

* What is a network trace?
* What is Wireshark?
*Basic Ul
* Some of the most useful parts of the Ul.
*Packet Capture
* How do we capture packets?
*Trace Analysis
*individual Packet Analysis
*Filters

*Exercises




Introduction

‘Network Traffic Trace

* A recording of the network packets both received
by and transmitted from a network interface.

*What is a pcap file?
* pcap = Packet Capture
* File format originally designed for tcpdump/libpcap.

* Most widely used packet capture format.




Introduction

*\What is Wireshark?

* A graphical network packet analyser.
 Found at http://www.wireshark.org
* The complete manual is located here.

\What some are it's uses?

* Troubleshoot network problems.
* Learn network protocol internals.
* Debug protocol/program implementation.

* Examine network-related security issues.

-



http://www.wireshark.org/
http://www.wireshark.org/docs/wsug_html_chunked/
http://www.wireshark.org/
http://www.wireshark.org/docs/wsug_html_chunked/

Basic Ul

i test.cap

Eile Edit Yew Go Capture Analvze 3Statistics  Telephony  Tools  Internals  Help

B e BEXSEI AT I BEE

Filker: M Expression, .,

Mo, Tirne Source Destination Protocol  |Length | Info
1 0.000000 192.168.0.2 Broadcast ARP 42 Gratuitous ARP for 192.168.0.2 (FE
2 0.20013% 102.168.0.1 152.168.0.2 MEMS G2 pame guery NESTAT *<00><00><005<C

4 1.0256859 162 168.0.2 224.0.0.22 IGMP 54 w3 Membership Report / Join group
5 1.044365 1592.168.0.2 1%2.168.0.1 DS 110 standard_guery sSRv _ldap._tcp.nbc
6 1.048652 192.168.0.2 239.255.255.250 SSDP 175 List
Fl.0507Y8d 192.1a8.0.2 152.1a8.0.1 DhS S0A nkblooeld, wwdod
B 1.055053 192.168.0.1 192.168.0.2 SSDP . (0] .4
O 1.082038 192.168.0.2 152 .168.0.255 MEMS 110 istration ME NELOOELD<00:>
10 1.121%45 1592.168.0.2 1%2.168.0.1 DS 87 standard query A proxycont. wwiod,
11 1.226156 192 168.0.2 152.168.0.1 TCP 62 ncu-2 > http [S¥M] Seq=0 win=86424
12 1.227282 192.1e8.0.1 152 . 1a8.0.2 TCP 60 http = ncu-2 [S¥N, ACK] Seg=0 AckM
| 1 | (2]
Frame 11: 62 kbytes on wire (456 bits), 62 bytes captured (496 bits)
Ethernet II, Src: 152.168.0.2 (00:0b:5d:20:cd:02), Dst: Metgear_2d:75:%a (00:09:5b:2d:75:9a)
Internet Protocol, Src: 192.168.0.2 (1%2.168.0.20, Dst: 1%92.168.0.1 (1592.168.0.1)
= Transmission Control Protocol, Src Port: ncu-2 (315960, Dst Port: http (800, Seq: 0, Len: O
Source port: ncu-2 (31967 =
Cestination port: http (80D
[Etream dndex: 5]
Seguence number: O {relative sequence number’) =
Header length: 28 lytes PaCI(et DEtaIIS_
Flags: 0x02 (S¥N)
window size value: 64240 v
Qooo 00 09 5h 2d 75 9a 00 Ob 5d 20 cd 02 08 00 45 00 I T .
Qolo 00 30 18 48 40 00 80 06 61 2c c0 aB 00 02 cCO as LOLUHE. L. a,
OozZ0o 00 01 Oc Fco 00 50 3¢ 36 95 8 00 00 00 00 FO 02 ...II.F'{Eu

0030 fa fO 27 20 00 00 02 04 05 b4 01 01 04 Q2 e e

Packet Bytes

@ File: "C:jtest.cap” 14 KB 00:00:02 | Packets: 120 Displayed: 120 Marked: 0 Load time: 0:00,000 ' Profile: Default




*File -> Open

* Opens a packet capture file.
*View -> Time Display Format

* Change the format of the packet timestamps in the
packet list pane.

* Switch between absolute and relative timestamps.
* Change level of precision.

View -> Name Resolution

e Allow wireshark to resolve names from addresses
I at different protocol layers.

i



*Capture -> Interfaces

Available network
Interfaces for capture.

Total packets per
Interface.

Packet rate per interface.

&)p37p1

ELG

glany  Pseudo-device that captures on a

Wireshark: Capture Interfaces

IP Packets Packets/s @ stop
192.168.011 55 0 |a5tart ||H0ptions |
unknown 0 0 |a5tart ||u0ptions |
unknown 71 0 |&Start ||H0pti0ns |
127.00.1 16 0 |55tart ||H0ptions |




B 3 s

Wireshark: Capture Options

*Capture -> Options

Interface: [eml

IP address: 192.168.0.11, fe80:218f3fffele: 4256

(] S et Va ri O u S C a pt u re Link-layer header type: Wireless Settings
M Capture packets in promiscuous mode Buffer size: megabyte(s)

Capture packets in monitor mode

p a ra m ete rS . [] Capture packets in pcap-ng format

[l Limit each packet to |65535 _ bytes

. ‘iCapture Filter:| ’ | v ‘ | Compile BPF
ot P rO m I S C O u S m O d e Capture File(s) Display Options

= ’ l |[ﬁBrowse...‘ & Update list of packets in real time

[[] Use multiple files

* On - record all packets ooy [

Next file every | 1

reaching the interface. bttty [

Stop capture after |1

 Off - record only those o L e
packets directed to the o [ ;
host. Ot || @stan |

megabyte(s) - & Automatic scrolling in live capture

minute s) M Hide capture info dialog

files
Name Resolution

file(s)
M Enable MAC name resolution

[| Enable network name resolution

[ .. after |1 megabyte(s)

—  Enable transport name resolution
els)




*Analyze -> Follow TCP Stream

* Applies a filter to follow a single tcp conversation
within the trace.

* Displays the reassembiled data section of each
packet in the conversation.

* Useful for debugging or analyzing any TCP based
application layer protocol.

* HTTP, FTP, SSH, LDAP, SMTP, etc.




*Statistics -> Protocol Hierarchy

* Presents descriptive
statistics per protocol.

* Useful for determining the
types, amounts, and
relative proportions of
protocols within a trace.

Display filter: none

Protocol

V Ethernet
Address Resolution Protocol
V Logical-Link Control
Spanning Tree Protocol
¥ Cisco Discovery Protocol
Malformed Packet
Logical-Link Control Basic Format XID
¥ Internet Protocol Version 6
¥ User Datagram Protocol
DHCPv6
Domain Name Service
Hypertext Transfer Protocol
Internet Control Message Protocol v6
¥ Internet Protocol Version 4
¥V User Datagram Protocol
Domain Name Service
Dropbox LAN sync Discovery Protocol
Bootstrap Protocol
Common Unix Printing System (CUPS) Browsing Protocol
¥ NetBIOS Datagram Service
¥ SME (Server Message Block Protocol]

11

il
B

011%
450] 0,09 %
210| 0.04 %
204 0.04 %

36| 0.01 %
175] 0,02 %

103013 [99.68
3912 1.00 %
2573] 060 %

486 011 %
484[ 022 %
39 001%]
555

55] 0,02 %

X Close

LN




eStatistics -> Conversations

* Generates descriptive
statistics about each
conversation for each
protocol in the trace.

Ethernet: 214]| Fibre Channel |FDDI | 1Pv4: 400 | 1Pv6: 87| IPX | IXTA [NCP [RsvP [SCTP | TCP: 1325 | Token Ring | UDP: 1374 |us8 | wiLaN
Ethernet Conversations
Address A Address B Packets Bytes Packets A—B Bytes A—B Packets A<B
Brocade C_ef 8b:00 ‘Broadrast 753: 59 280: 753: 59 280: DI
Spanning-tree-(for-bridges)_00: Cisco_ed:4e:59 609: 38 976: 0: 0: 609
Dell_77:19:25 ‘Broadcast : 486: 29 343 486 29 343 0
Dell_77:19:25 ‘IPv6mcast_00:01:0002 - 16 2352 16 2352 0
Dell_45:24:bb ‘Broadcast : 2 120: 2 120: 0
CadmusCo_e5:ac:58 Gisco-Li_c1:d1f9 i 101 328:77 500 345 42 867. 5114212 58 461
Dell_9e:44:b0 ‘Broadcast ; 165 26 054 165 26 054 0
QuantaCo_8f:42:cd ‘Broadcast ; 40 2 400 40 2 400 0
Dell_d5c7-3b ‘Broadcast : 67 4625 67 4625 o
IntelCor_3d:19:63 ‘Broadrast o 420: o 420: 0.
>

(& Name resolution

[ Limit to display filter

Follow Stream




*Statistics -> Flow Graph

* Generates a sequence
graph for the selected
traffic.

* Useful for understanding
sed. and ack.
calculations.

Time

41552
41561
41561
41561
41.568
41622
41622
41622
41622
41622
41622
41622
41622
41622
41622
41623
41623

traffic_trace pcap

- Graph Analysis
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ACK
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Comment

Seq=0
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{50485 § ACK 410) Seq = 285 Ack = 7633
I > | | -




Packet Capture

*Interface selection
e Capture -> Interfaces

* Select the interface from which to capture packets.

* any — captures from all interfaces

* lo — captures from the loopback interface (i.e. from localhost)

* Set the desired capture parameters under the options
menu.

*Start Capture

 Click the start button next to the desired interface.

* Captured traffic will be displayed in the packet list pane.

-




Packet Capture

*Stop Capture
* Select Capture -> Stop
*Saving Capture

* Once the capture has been stopped select File ->
Save As.

* From the save dialog you can specify file type and
which packets to save via the packet range
menu.




Trace Analysis

i test.cap

Eile Edit Yew Go Capture Analvze 3Statistics  Telephony  Tools  Internals  Help

B e BEXSEI AT I BEE

Filker: M Expression, .,

Mo, Tirne Source Destination Protocol  |Length | Info
1 0.000000 192.168.0.2 Broadcast ARP 42 Gratuitous ARP for 192.168.0.2 (FE
2 0.20013% 102.168.0.1 152.168.0.2 MEMS G2 pame guery NESTAT *<00><00><005<C

4 1.0256859 162 168.0.2 224.0.0.22 IGMP 54 w3 Membership Report / Join group
5 1.044365 1592.168.0.2 1%2.168.0.1 DS 110 standard_guery sSRv _ldap._tcp.nbc
6 1.048652 192.168.0.2 239.255.255.250 SSDP 175 List
Fl.0507Y8d 192.1a8.0.2 152.1a8.0.1 DhS S0A nkblooeld, wwdod
B 1.055053 192.168.0.1 192.168.0.2 SSDP . (0] .4
O 1.082038 192.168.0.2 152 .168.0.255 MEMS 110 istration ME NELOOELD<00:>
10 1.121%45 1592.168.0.2 1%2.168.0.1 DS 87 standard query A proxycont. wwiod,
11 1.226156 192 168.0.2 152.168.0.1 TCP 62 ncu-2 > http [S¥M] Seq=0 win=86424
12 1.227282 192.1e8.0.1 152 . 1a8.0.2 TCP 60 http = ncu-2 [S¥N, ACK] Seg=0 AckM
| 1 | (2]
Frame 11: 62 kbytes on wire (456 bits), 62 bytes captured (496 bits)
Ethernet II, Src: 152.168.0.2 (00:0b:5d:20:cd:02), Dst: Metgear_2d:75:%a (00:09:5b:2d:75:9a)
Internet Protocol, Src: 192.168.0.2 (1%2.168.0.20, Dst: 1%92.168.0.1 (1592.168.0.1)
= Transmission Control Protocol, Src Port: ncu-2 (315960, Dst Port: http (800, Seq: 0, Len: O
Source port: ncu-2 (31967 =
Cestination port: http (80D
[Etream dndex: 5]
Seguence number: O {relative sequence number’) =
Header length: 28 lytes PaCI(et DEtaIIS_
Flags: 0x02 (S¥N)
window size value: 64240 v
Qooo 00 09 5h 2d 75 9a 00 Ob 5d 20 cd 02 08 00 45 00 I T .
Qolo 00 30 18 48 40 00 80 06 61 2c c0 aB 00 02 cCO as LOLUHE. L. a,
OozZ0o 00 01 Oc Fco 00 50 3¢ 36 95 8 00 00 00 00 FO 02 ...II.F'{Eu

0030 fa fO 27 20 00 00 02 04 05 b4 01 01 04 Q2 e e

Packet Bytes

@ File: "C:jtest.cap” 14 KB 00:00:02 | Packets: 120 Displayed: 120 Marked: 0 Load time: 0:00,000 ' Profile: Default




Trace Analysis

*Packet list

* Displays all of the packets in the trace in the order they were
recorded.

e Columns

Time — the timestamp at which the packet crossed the
Interface.

Source — the originating host of the packet.

Destination — the host to which the packet was sent.

Protocol — the highest level protocol that Wireshark can detect.

Lenght — the lenght in bytes of the packet on the wire.

Info — an informational message pertaining to the protocol in

| the protocol column.




*Packet list

Trace Analysis

* Default Coloring

Gray — TCP packets

Black with red letters — TCP Packets with errors
Green — HTTP Packets

Light Blue — UDP Packets

Pale Blue — ARP Packets

Lavender — ICMP Packets

Black with green letters — ICMP Packets with errors

* Colorings can be changed under View -> Coloring Rules

A




Individual Packet Analysis

i test.cap

Eile Edit Yew Go Capture Analvze 3Statistics  Telephony  Tools  Internals  Help

B e BEXSEI AT I BEE

Filker: M Expression, .,

Mo, Tirne Source Destination Protocol  |Length | Info
1 0.000000 192.168.0.2 Broadcast ARP 42 Gratuitous ARP for 192.168.0.2 (FE
2 0.20013% 102.168.0.1 152.168.0.2 MEMS G2 pame guery NESTAT *<00><00><005<C

4 1.0256859 162 168.0.2 224.0.0.22 IGMP 54 w3 Membership Report / Join group
5 1.044365 1592.168.0.2 1%2.168.0.1 DS 110 standard_guery sSRv _ldap._tcp.nbc
6 1.048652 192.168.0.2 239.255.255.250 SSDP 175 List
Fl.0507Y8d 192.1a8.0.2 152.1a8.0.1 DhS S0A nkblooeld, wwdod
B 1.055053 192.168.0.1 192.168.0.2 SSDP . (0] .4
O 1.082038 192.168.0.2 152 .168.0.255 MEMS 110 istration ME NELOOELD<00:>
10 1.121%45 1592.168.0.2 1%2.168.0.1 DS 87 standard query A proxycont. wwiod,
11 1.226156 192 168.0.2 152.168.0.1 TCP 62 ncu-2 > http [S¥M] Seq=0 win=86424
12 1.227282 192.1e8.0.1 152 . 1a8.0.2 TCP 60 http = ncu-2 [S¥N, ACK] Seg=0 AckM
| 1 | (2]
Frame 11: 62 kbytes on wire (456 bits), 62 bytes captured (496 bits)
Ethernet II, Src: 152.168.0.2 (00:0b:5d:20:cd:02), Dst: Metgear_2d:75:%a (00:09:5b:2d:75:9a)
Internet Protocol, Src: 192.168.0.2 (1%2.168.0.20, Dst: 1%92.168.0.1 (1592.168.0.1)
= Transmission Control Protocol, Src Port: ncu-2 (315960, Dst Port: http (800, Seq: 0, Len: O
Source port: ncu-2 (31967 =
Cestination port: http (80D
[Etream dndex: 5]
Seguence number: O {relative sequence number’) =
Header length: 28 lytes PaCI(et DEtaIIS_
Flags: 0x02 (S¥N)
window size value: 64240 v
Qooo 00 09 5h 2d 75 9a 00 Ob 5d 20 cd 02 08 00 45 00 I T .
Qolo 00 30 18 48 40 00 80 06 61 2c c0 aB 00 02 cCO as LOLUHE. L. a,
OozZ0o 00 01 Oc Fco 00 50 3¢ 36 95 8 00 00 00 00 FO 02 ...II.F'{Eu

0030 fa fO 27 20 00 00 02 04 05 b4 01 01 04 Q2 e e

Packet Bytes

@ File: "C:jtest.cap” 14 KB 00:00:02 | Packets: 120 Displayed: 120 Marked: 0 Load time: 0:00,000 ' Profile: Default




Individual Packet Analysis

Packet Detalls

* Detailed information about the currently selected packet is
displayed in the packet details pane.

* All packet layers are displayed in the tree menu.

* Any portion of any layer can be exported via a right click and
selecting Export Selected Packet Bytes

*Packet Bytes
* Displays the raw packet bytes.

* The selected packet layer is highlighted.

-




*Filters

* Packets captures usually contain many packets irrelevant to
the specific analysis task.

 To remove these packets from display or from the capture
Wireshark provides the ability to create filters.

* Filters are evaluted against each individual packet.
* Boolean expresions dealing with packet properties.
* Supports regular expressions.

* Can either be manually constructed, composed via the
Expressions menu or composed based on a selected
packet's properties.

-




*Expressions Menu

Field name - selects the
packet property.

Relation - selects the
boolean test.

Predefined values - common
values against which the
selected packet property is
tested.

Value - Arbitrary Textual or
Numeric value against
which the selected packet
property is tested.

Wireshark: Filter Expression - Profile: Default

Field name

Relation

Value (protocol)

Ty T T Ty e e
B~ HP_ERM - HP encapsulated remote mirrori

B HPEXT - HP Extended Local-Link Control
B HPSW - HP Switch Protocol

B HPTEAM - HP NIC Teaming Heartbeat

B HSRP - Cisco Hot Standby Router Protoco

http.notification - Notification (TRUE if

http.response - Response (TRUE if HTT
http.request - Request (TRUEif HTTP 1
http.authbasic - Credentials

http.request. method - Request Method
< I

|
kS
<
n=
£=

contains

matches

e

Predefined values:

Range (offset:length)

@Gl || JOK |




*Compound Filters

* Filters can be composed of multiple tests joined with boolean
connectives.

* && - logical conjuction (i.e. AND)
* || - logical disjunction (i.e OR)
* | -]ogical negation (i.e. NOT)
* Supports the order of operations.
*Regular Expressions

* Fields can be evaluated against a regular expression using the
“matches” test.

* Uses Perl regex syntax.

A y


http://www.cs.tut.fi/~jkorpela/perl/regexp.html
http://www.cs.tut.fi/~jkorpela/perl/regexp.html

*Filter Text Box

* Green - valid filter
* Red - invalid filter
* Yellow - may produce unexpected results

Packet based filters

* Filters can be constructed on the basis of individual packets
by right clicking on a packet and selecting either:

* Prepare as filter — creates a filter.
* Apply as filter — creates a filter and applies it to the trace.

* Follow TCP Stream — creates a filter from a TCP packet's
stream number and applies it to the trace.

-




*Filter examples

* http.request - Display all HTTP requests.

http.request || http.response - Display all HTTP request and
responses.

ip.addr == 127.0.0.1 - Display all IP packets whose source or
destination is localhost.

tcp.len < 100 - Display all TCP packets whose data length is
less than 100 bytes.

http.request.uri matches “(gif)$” - Display all HTTP requests
in which the uri ends with “gif”.

dns.query.name == “www.google.com” - Display all DNS

I queries for “www.google.com”.




Questions

Any Questions?

Thank you for your attention!




*Work in groups of 2.

Download the trace at
http://cs.uga.edu/~neasbitt/files/userl tcpdump.pcap

*Answer the following questions on a sheet of paper.

What is the total number of HTTP Post requests in the trace?

What is the status code for the last HTTP response in TCP
stream 177

What is the total size in bytes for all packets containing
JavaScript Object Notation (JSON) data?

Between which two IP address where the most IP packets
sent?

What is pictured in the image bostonmusic-promo.jpg?

i


http://cs.uga.edu/~neasbitt/files/user1_tcpdump.pcap
http://cs.uga.edu/~neasbitt/files/user1_tcpdump.pcap

*Work in groups of 2.

*Download the trace at
http://cs.uga.edu/~neasbitt/files/userl_tcpdump.pcap

*Answer the following questions on a sheet of paper.

Question Answers
1.8

2. 302
3. 2253

What is the total number of HTTP Post requests in the trace?

What is the status code for the last HTTP response in TCP
stream 177

What is the total size in bytes for all packets containing
JavaScript Object Notation (JSON) data?

Between which two IP address where the most IP packets
sent?

What is pictured in the image bostonmusic-promo.jpg?

4.10.0.2.15-123.125.114.18

5. A stereo system.

i



