CSCI 1100

Internet Exercise

Topics covered on this exercise:

1. Tabbed browsing

2. Changing your UGA password

3. Registering your student ID with our system.

4. WebCT online homework

5. Web browser tips and tricks

6. Searching for Web sites

7. Creating and organizing bookmarks

8. Browsing and subscribing to mailing lists

9. Using Wikipedia

10. Contributing to a Content Management system

11. Setting up Mozilla Thunderbird as an email client

12. Gallery of interesting social networking Web sites

Prerequisites: This exercise requires changing your profile information on Windows, so it should be done while logged in with your regular Windows account.  If you are having problems logging in to your own CS account, using the temporary lab account is fine.

Most of these exercises will work with any Web browser on your system. However, the specific menus and menu names may be different or found in different places for each Web browser. The notes and screenshots below assume you have started out using Firefox.

1. We will be using both Mozilla Firefox AND Internet Explorer at different sections of this exercise.  Pay attention for when we switch from one to the other.  First, launch the Mozilla Firefox browser.

2. Once the Firefox browser opens, press the Ctrl-T key combination. A new browser tab will appear, labeled (Untitled). Click on this tab and enter www.uga.edu into the location window.[image: image22.png]User login
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 Now you can flip back and forth between the two tabs.

3. Tabbed browsing is especially useful when you want to follow a link without losing the thread of the original page. Pick any link on the UGA page. Right-click on the link and choose “Open Link in New Tab.” (Alternatively, to open a new link in a new tab, hold down Ctrl and then Left Click on the link.)

4. Note that the currently active tab is highlighted with its own [image: image23.png]Startup
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close button. Try clicking on the big close button at the top right of the Firefox window. Since you have multiple tabs open, Firefox warns you all tabs will be closed.  Cancel out of this and keep Firefox open.

5.  Using Firefox, go to https://myid.uga.edu/   DO NOT log in. Instead, scroll down to the Policies section and click on the link Password Security Requirements to discover what they call a “strong password.”  You do not need to change your password if it is already secure.

6. Go to webct.uga.edu and log in.  Click on Dr. Robinson's class link.  On Dr. Robinson's WebCT main page, click the Students Tools picture. Inside the student Tolls page click on My Grades icon to view your grade. (If you don't see the button, it could be under repair; we'll try this some other time). There is an easier way to go to My Grades page. On your left hand side you will see a Hyperlink called My Grades, click on that. (Hyperlink is a text, which when clicked on will lead you to a different web page).

7. WebCT makes extensive use of pop-up windows; you need to turn off pop-up blocking for popups coming from WebCT. Here is how to do it on Firefox:

From the Tools menu, choose Options and click the Content tab. You could uncheck the “Block pop-up windows” checkbox, but this would expose you to a blizzard of annoying pop-up add windows. Instead, click the Exceptions button on the right hand side of the window. Add “webct.uga.edu” to the list of Exceptions. Now WebCT can open pop-ups on your computer.
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Now click on the Privacy tab in the Options panel. Here you will see some options for managing your browser cookies. Cookies are small bits of information that are stored on your computer by Web sites you visit, and then returned to the Web site when you make a new request. Cookies help Web sites to recognize you when you return, which can be useful but may also compromise your privacy. Set the option to keep cookies only until you close Firefox. [Note: you will want to change this setting if you want to use this computer to access commercial sites where you have an account, such as Amazon or eBay.]
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Still in the Options panel, click the Show Cookies… button. Since you have just started browsing with Firefox, you should not see many cookies. However, you should see a folder “uga.edu.” Opening this folder you will see an entry labeled WebCT Ticket. This cookie helps WebCT “remember” that you are an authorized user. If you look at the content of the cookie, you will see your UGA MyID plus a bunch of gobbledygook – scrambled codes to verify that you really are who the cookie says you are! 

10. Can you guess what would happen if this cookie were deleted? Let’s find out! Select the WebCTTicket cookie, then click the Remove Cookie button, then click Close to close this dialog. Click OK to close the Options dialog and apply your changes. Go back to the WebCT browser window and click the reload button[image: image1.png]


. You will find yourself back at the initial login screen! Can you explain why?

11. Go back to the Tools/Options menu item and click the Security tab. Make sure the option, “Tell me if the site I am visiting is [image: image26.png]7 Welcome to the University of G




a suspected forgery,” is selected. These forgeries are called phishing Web sites. A phishing site masquerades as commercial site such as an online banking or PayPal site, and attempts to fool you into typing in your login and password credentials. 

12. Now close Firefox and launch Internet Explorer. Since this is your first time using IE on this machine, you might be confronted with some configuration questions. If  IE asks if you want to turn on the Phishing Filter, do so.  We strongly recommend using these filters in all your Web Browsing.

13. Do you see the menu bar [image: image2.png]Edt Vew Favortes Tooks Help



 in Internet Explorer? Press the Alt key to turn the menu bar on or off.

14. Go to http://www.google.com.  Let’s bookmark this site as a Favorite.  Let’s also put it in a Favorite folder called Search Engines.  Here’s how: click the Add To Favorites button (it looks like a “plus star” [image: image3.png]


), then select “Add To Favorites…”.  A window will pop up.  To make a new folder, click the New Folder button.  Type in the folder name we want to make (Search Engines) then click Create.  Notice the “Create in:” box has changed to our new folder we just made.  Now click the Add button and our bookmark goes right into that folder.

For the following questions, type the answers right into this document.

15. Use IE’s Live Search (in the top right-hand portion of the web browser) to find out who was the keynote speaker at the dedication of the Coverdell Center in 2006.  Hint: Think of a few keywords that are likely to be present in the article, like Coverdell Center, dedication, and speaker. 

16. Try doing this same search on the local Google search engine attached to UGA. Go to the UGA Web site http://www.uga.edu. Click the Search link at the top right of the page. Use the “Search UGA Web sites” to find the celebrity guest speaker at the Coverdell dedication. 

17. Using Live Search, what is a “Minie ball?”

18. Bookmark the site www.uga.edu as a Favorite.  Put this bookmark into a bookmark folder named UGA.

19. Inside the UGA bookmark folder, create a subfolder called CSCI 1100 (you’ll need to change the “Create in:” box to point to your UGA folder, then select “New Folder” again to make a subfolder. Navigate to http://ganesha.cs.uga.edu/drupal-5.2. Create a bookmark titled Drupal. You will be returning to this link later on in this exercise.

20. Go to the UGA Listserv page at http://www.listserv.uga.edu/ and choose the Browse link. Scan down the page looking for interesting lists to join. 

21. [image: image27.png]Search results

Mo list matches your search string



Use the CataList link to search for listservs about the Civil War. You should find several at different schools. Now go back and search for listservs about Minie balls. There is nothing that specialized!

22. Navigate to the outstanding reference site Wikipedia.org. This encyclopedia is populated by voluntary contributions from individuals all over the world, so there is an incredible wealth of information here. The reliability is usually quite good.

23. Search for the article on Francis Birtles, an Australian adventurer of the 1920’s. 

24. Using Wikipedia, what is “spyware”?

25. Now we will actually practice putting content onto a content management system. Use your saved bookmark to visit the CSCI 1100 Drupal website. In computing parlance, a sandbox is an isolated system in which you can make mistakes without damaging anything outside the sandbox.

26. Drupal is a work in progress.  If one of the below features (i.e. the Forum or FAQ) is not available, don't fret!  It's just because Dr. Dan is still figuring out all of its cool features.  [image: image28.png]iGoogle | Sign in



First, create a user account. Please use your UGA MyID so you can easily remember it. Your password will be sent to the email that you specify. When you get the password, return to the site and log in.

27. When you have logged in, click on account and choose the Edit tab. Customize your Drupal account by choosing one of the themes shown on the page. Feel free to try out the various themes. Note that the “Meta” themes each have a set of buttons allowing you to alter the color scheme on the fly.

28. Now choose Content and click on Create Content. Start by creating a blog entry. “Blog” is short for “Web Log” and represents a sort of online diary. As you are typing the text, just type as you would normally. To create a new paragraph, just enter a blank line. A good content for your first blog entry would be a self-introduction. Be aware that all blogs are public! Whatever you write will be visible to all the students. 

29. Now click on the Forums link and examine the discussion areas there. If you are so inclined, browse the comments and add your own comment or start a new forum topic.

30. Check out the FAQ link. This area is intended as a collaborative bulletin board for you to post notes that are helpful for yourself and other students studying for the tests. The categories will expand as the term progresses.

Google page customization

Launch Internet Explorer and go to http://www.google.com. Click on iGoogle [image: image29.png]CNN.com
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at the top right. You will be sent to a page that allows you to customize your Google search page.

Enter your Zip code into the text box in the Weather component. You will now see the weather forecast for Athens (or wherever you live).

Click the down-pointing arrow on the CNN component and choose Edit settings. [image: image30.png]Cookies
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 Change the number of news items displayed and click Save. This shows you how to customize a component. Try the editing options on each of the other displayed items. Note that you can change the Weather component to display the temperature in Celsius if you like.
Using your mouse, grab the top bar of the CNN component and drag it directly under the clock display. The ability of Web sites to perform this kind of highly interactive behavior is quite new, and was pioneered by Google. These folks are smart!

You may experiment with Google page customization without creating an account, but you must create an account in order to save your personalized page. We do not require you to create an account for this course, but there’re tons of cool games (Frogger, Asteroids, etc) to add and play if you ever get bored at the SLC.  

Controlling Internet Explorer Settings

In IE, choose Tools->Pop-up Blocker-> Pop-up Blocker Settings. This tool allows you control which sites are allowed to pop up windows on your machine. Add webct.uga.edu to the list of sites, because WebCT uses pop-ups to deliver your online quizzes. Then click Close to save the new settings.
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Choose Tools -> Internet Options. Explore the various settings that you are allowed to change. Note that you can use this panel to change your IE home page (the page that loads when you first launch IE).

Look up two favorite Web sites in some category of interest, such as two sports sites or two sites about movies. (if your menu bar is turned off, press Alt to turn it back on).  For each site, use Favorites->Add to Favorites to add the site to your Favorites list (these are called Bookmarks in other browsers).

Now select Favorites->Manage Favorites. Create a new folder named after your category, such as Sports Sites or Movies Sites. Then move your two newly created favorites into the new folder. 

Note that this version of IE comes without the standard menu set (File menu, Edit menu, etc.) Select View->Toolbars and experiment with turning the various toolbars and Explorer Bar options on and off.

Mozilla Firefox settings

Launch the Mozilla Firefox browser, which has a rich collection of customization options.  First, select Tools->Options->Main.  First, decide on what you want to happen when Firefox starts up. For purposes of this course, it is often convenient to have [image: image31.png]Site
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Firefox start by taking you to WebCT, as shown here. Please make sure you are logged into WebCT before starting the next part.
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Creating a Google account, and using Gmail.

Gmail is a free, search-based webmail service that combines the best features of traditional email with Google's search technology. Besides offering an entirely new way of reading and tracking messages, Gmail includes over 5 GB of storage space. 

Your Google Account gives you access to Gmail and other Google services like Picasa, Web History and more. Here is how you can create a Google account:

1. Launch Firefox and go to http://www.gmail.com
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Click on Sign up for Gmail at the lower right corner. You will be redirected to the “Create an Account” page.

3. Enter your first name and last name.

4. Enter your desired login name, which will be also used as your Gmail address. Click on check availability! If the username is not available, you will be offered a few similar but available usernames by Google. You can either choose one of the offered usernames, or enter a new one and check if it is available using the same method. However, if the username is available, it will say that the username is available, and you can continue.  [image: image5.png]Desired Login Name:  [JSriicsTioo ———— @gmal.com
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5. Next you should choose a password for your account, and the re-enter it in the appropriate box. It is recommended that you choose a password that is easy for you to remember, but difficult for others to guess. Your password should be at least 8 characters long. As you type in your password, Google will tell you if it is a strong one.
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If you check Remember me on this computer, next time that you close the browser and open it again, when you go to http://www.gmail.com you won't be asked for your user name and password. Since it is a lab computer, I would recommend you leave this box unchecked.

7. Sometimes after a daunting search you find your favorite website, but after a while you can't find it anymore. You have either deleted your history, or simply have forgotten to save the website in your Favorites. With Web History, you can view and search across webpages you've visited in the past, including Google searches. If you check Enable Web History, all that you search for on Google (when you are log on to your Google account) will be stored on Google servers, which means that you can view and manage it from any computer.

8. Choose a security question from the drop down list. Then type in the answer in the next box. You will be asked this question if you forget your password and want to retrieve it. [image: image6.png]What is your primary frequent fiyer number ~
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9. If you have another email address, you can provide it as a secondary email. This address is used to authenticate your account should you ever encounter problems or forget your password. You may leave it blank. 
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10. To verify that you are an actual human that is registering for the email account and not an automated malicious program, you need to type in the twisted graphical word in the box below it.
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11. Next you need to read the Terms of Service. If you agree to the Terms of Service and Privacy Policy of Google, you can go ahead and click on I accept. Create my account. 
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12. If you have made any mistakes, it will be shown in red. You will have to correct that step, and go through the Word Verification again.

13. Finally, you will see a Congratulations message in the Introduction to Gmail page. When you are ready, click on I'm ready – show me my account. This link is on your right.

14. You will be redirected to your actual Gmail account. There should already be a welcome email from Gmail team. Read it later.

Congratulations! You have successfully created your Gmail account, and can enjoy it later. Before you start working with Mozilla Thunderbird in the next section, there are a few more steps you need to follow in order to prepare your Gmail account for IMAP. IMAP is a protocol for accessing your emails on mail servers.

Configuring Gmail for IMAP

15. Click on Settings. It is on the top right corner. [image: image10.png]jsmithcs1100@gmail.com {SettingS) Older version | Help | Sign out




16. Click on Forwarding and POP/IMAP.
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17. Choose Enable IMAP.
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18. Click Save Changes.
You are done with Gmail. It is ready to be accessed by your IMAP email client. We will use Mozilla Thunderbird for this purpose.

Configuring Mozilla Thunderbird, an IMAP mail client.
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Launch Mozilla Thunderbird, a mail reader program. Thunderbird is an email client program, meaning that it communicates with a server program to read and process mail. Of course you can use a Web browser to read your email, but you will see that using a special client program gives you more functionality.  

Thunderbird may come up with a configuration dialog already open. If not, use the Tools menu and select Account Settings.... Thunderbird may come up with a configuration dialog already open. If it does not come up, click on  Add Account...

Here are the answers to give:

1. When it asks what type of account, click [image: image13.png]@' Email account’




2. Your real name and gmail address:         [image: image14.png]Your Name: John Smith
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3. Select IMAP account [image: image15.png]O pop




4. Set the incoming and outgoing servers as:
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5. Your “incoming user name” is your username including  @gmail.com   [image: image16.png]Incoming User Name: | JSmith@gmail.com




6. Name the account anything you like: [image: image17.png]ficcount Hame: €5 Lab Account|
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 the Tools menu, choose Account Settings and then Server Settings from the folder list below your new account. 
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Note the Port: field, which is automatically set to 143. This is a TCP port number and gives the “address” where the IMAP service is waiting to receive client inputs. 
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The next group of settings allows you to encrypt your communications with the email server. This will ensure that if someone tried to intercept your email, all they would see would be encrypted garbage. Select SSL.

At this point the port number should change from 143 to 993. IMAP servers like imap.gmail.com listen on port 143 for an unencrypted IMAP message, but on port 993 for encrypted IMAP messages. Click OK to save these configuration settings.

Finally, we need to set a space on your computer for local mail folders. “Local” means that the mail will be kept on your own computer instead of on the server. Click the Start button and find your My Computer tool. Navigate to the I: drive and create a new folder named IMAP Mail. Now go back to the Thunderbird account setup (Tools -> Account Settings) and choose “Local Folders” from the left hand menu.  Under the Message Storage section, choose your new folder as your local[image: image40.png]=€ Lab Account
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 directory. Click OK to save these configuration settings.

Now you should be ready to read your mail! Thunderbird already knows your gmail username, but you will need to provide your password to read mail. If everything goes smoothly, you should see your gmail. Sweet!
Let’s configure your outgoing email server, so that you can send out emails using Thunderbird. 

1. In Thunderbird, go to Tools -> Account Settings, and choose Outgoing Server (SMTP) from the left.

2. Now, from the list on your right select your Gmail outgoing mail server, which you had set as smtp.gmail.com. Click Edit. [image: image18.png]Although you can specify more than one outgoing server (SMTP),this is only
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3. Now, set Port to 587. For connection security choose TLS. Your username should be your Gmail username including @gmail.com . Click OK. 
If everything goes smoothly, you should be able to send emails using Thunderbird.
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Custom sorting: Find the Sender tab in the upper-right window and click on it. You should see the emails now sorted alphabetically sorted by sender. Try sorting on Subject. Now sort by Date, which will return you to the default sorting order.
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Custom mail folders:Now let’s organize your mail by creating folders. Right-click on the Local Folders icon, then select New Folder.... Create a folder named CSCI 1100 and a folder named Personal, both inside Local Folders. 

Click on the Personal folder and create a subfolder named Music.[image: image43.png]


 If you like, create other folders as well. Now try dragging a message from the Inbox window into one of your local folders. Alas, these local folders aren’t accessible from outside Boyd hall. 

Mail filters: From the Tools menu, choose Message Filters. Set the “Filters for:” dropdown box to your IMAP account. This means that the filters we define will apply to incoming messages from the mail server, delivered to your local computer by the IMAP protocol.
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 to define a new filter. Name this filter Music filter. Configure this filter by specifying that if the message subject contains the name of a certain band, the message will be diverted to your Music folder:
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Now use the Write tool on the Thunderbird toolbar to send a message to your Gmail account, with the name of your chosen band in the subject. Then click on the Music folder to see if the message has arrived there.

The Address Book: Click on the Address Book icon [image: image44.png]Sign up for Gmail



and try creating a new card for a friend. Note that you can also create mailing lists with the Address Book.

If you enjoy IMAP email, we hope you will try this out at home. The Thunderbird program is available for free download from Mozilla.org.
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Check your Junk Mail on Arches.

Back in your Web browser, return to http://www.ugamail.uga.edu/ and log in. Click the Folders link and examine your Junk Mail folder. EITS protects you from a lot of junk!

If you see any messages that are not spam, click on the This is Not Spam link. In this case you should add the sender to your Whitelist and move the message back to the Inbox. In future, messages from any sender on the Whitelist should always be delivered to you.
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Social Networking Web sites

To me, the single most provocative capability of the Web is empowering communication between regular old humans. This list of interesting “social networking” sites is a permanent work in progress – please send me your suggestions for sites to add to this list.

· Pledge Bank – users pledge to take some action, if others will also pledge

The End

Before you log out, ask your TA to help you check out.  The TA might ask you a few questions about the work you did today.  After the TA says it’s ok, you might want to get started with Microsoft Word Exercise. If the class is almost at the end then log out using the “Log off Vista” link on your desktop.


