Windows Exercise

Part I
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This exercise will require looking at the exercise directions (this document you are now reading) as well as the Windows desktop. It may be easier to see both at once by clicking the resize down button. This is the middle button in the group of three at the top right of your screen. If you click this button, you should be able to see the Windows desktop behind this document.

 To start off, familiarize yourself with a few terms that we’ll be using in the lab.  
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Cool Vista Stuff
Remember that your TAs are here to help you if you get stuck!

The Sidebar

1. If this is your first Vista experience, you might notice that the Start button looks different and you now have a “Sidebar” along the side of your screen.  Some people may find the Sidebar distracting.  Others may find it an easy way to goof off.  Either way, we’ll be exploring some Sidebar features.

2. The default sidebar should contain 1) the Clock gadget 2) the Slide Show gadget and 3) an RSS headline feed box (we’ll learn more on RSS feeds in a second).
3. Right click in a blank area of the sidebar (below the RSS feed box, for instance) and select Help.  The Windows Help and Support window should pop up.

4. Select the first question, “What is Windows Sidebar?” and read the explanation Windows provides. Click [image: image2.png]


 to close the Help and Support popup window.
5. Click the Clock gadget and drag it below the RSS feed gadget.  You can move the gadgets around if you prefer a different ordering.

6. Let’s add the Notes gadget to our Sidebar.  To find this gadget, open the Gadget Gallery by right clicking in an open area of the sidebar and choosing “Add Gadgets”, then double click the Notes gadget.
7. The Notes gadget will allow you to make reminders or notes to yourself… handy for quick things to remember to do while you are logged in to Windows.  Type in the note: “Note to self: go to the grocery store”.

8. You can download and install more gadgets from the Internet.  Go back to the Gadget Gallery (right click on the Sidebar and choose “Add Gadgets”).
9. Click the “Get more gadgets online” link at the bottom right-hand corner of the Gadgets Gallery window.

10. Windows should take you to a page of downloadable gadgets.
11. In the “Find More Gadgets” box at the top of the screen, type in “dictionary” and click search.

12. Find the “Dictionary Gadget”.  Don’t download it just yet.  Click the Dictionary Gadget image.  It will take you to a screen that tells you about the gadget.

13. You can now see who wrote the gadget, how much it costs (it should be free), and a description of the gadget.  

14. Since it would be convenient to have a dictionary right on the sidebar, click the Download button.

15. Windows should bring up a warning about downloading from people we don’t know.  Let’s assume this is a reputable person and click Install.

16. Click the ‘Open’ button.  You should get another warning from Internet Explorer.  Since we initiated this installation, click ‘Allow’.  Finally, click ‘Install’ one more time.  The gadget should then appear in your Sidebar.
17. Test it out.  Type in a word and click “Go”.  A definition window should pop up next to the gadget.

18. There are a bunch of different gadgets that we will not go into today, but if you have a Vista machine at home, I recommend a few games for downtown (Sidebar Pong is fun) and some sports scores gadgets when you’re away from your TV and too lazy to look scores up yourself.  

19. Now let’s play around with the RSS feed gadget.  Right click in an open area of the Sidebar and choose Help again.  In the search box at the top, type “RSS” and hit Enter.
20. Click the “What is a feed (RSS)?” link and read the paragraph on RSS feeds.

21. Let’s try subscribing to an RSS feed.  Open up Internet Explorer and go to http://www.google.com.  Find the icon next to our address bar that looks like [image: image3.png]


.  Notice that it is currently gray, meaning that Internet Explorer currently found no RSS feeds available on the website.  
22. Now go to the website http://www.news.com.  You’ll see the RSS feed icon has changed to orange, [image: image4.png]


, indicating it found RSS feeds on this site.  

23. Let’s add this RSS feed to our gadget.  Click the orange RSS feed icon on Internet Explorer.  It should take you to another page.  At the top of the webpage, click “subscribe to this feed” link, then click the “Subscribe” button.  

24. Minimize Internet Explorer to view your Sidebar.  Why didn’t the headlines show up in our gadget?  Click the View headlines link in our gadget again.  Neato!  Using the feed we subscribed to, our RSS feed gadget now has some headlines.  

25. Try clicking on the first headline.  A box with a snippet of the article should pop up.  To hide the article, click outside the RSS feed on the desktop. To get the whole article, click on the article title in the snippet box. 
Part II

Another change in Vista

A cool search functionality has been added to the Start button.  If you know a program’s name, just type it in the search box and a list is dynamically updated as you type.  For instance, the game Solitaire is located in All Programs -> Games.  Alternatively, try this:

1. Click the Start button and start typing the name of the program, Solitaire, in the search box.  

2. By the time you type S-o-l, the list box should contain the program you are looking for.  Neeeat.

3. Click the Start button and find the Computer icon button on the right. Right click on the C: drive and choose Properties. You will see how much total space is on the drive and how much is unused. If your C: drive gets very close to being completely full, you are in danger of having problems, because Windows needs to create temporary files on the C: drive. Note that this drive is a “local disk,” meaning that it is physically attached to your computer.

4. Now use the same trick to open the I: drive. You will see that this drive is listed as a Network drive instead of a local drive. Because it is a Network Drive, the I: drive is visible from any station on our local network. When you sit down at any machine in this lab, or in the open CS lab in room 307 upstairs, the contents of the I: drive will appear in your Computer icon. Unfortunately, you cannot access the I: drive from the Internet or at home.

5. Open the I: drive. Right click in an open area on the right side of the window, and then go to New -> Folder.  Windows creates a new folder named “New Folder”.  The label “New Folder” appears highlighted – this tells you that the name has been selected for editing. Type CSCI 1100 and press Enter. Your folder should now be named CSCI 1100.  
6. Use the same process to create another new folder named Personal Stuff. You should now have an open window that looks something like this:
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(If your window doesn’t look like the picture above, you may want to change the view of the window. To do that click on the Views button on the top and select the view that looks similar to the picture. )
7. Right-click on the Personal Stuff folder. (Clicking with the right mouse button gives you access to the advanced features of Windows.) Click on Rename with the left mouse button.  Rename the Personal Stuff folder to My Personal Stuff.

8. Press the PrintScreen key, which is near the upper-right area of your keyboard. Nothing visible happens, but a copy of your desktop has been stored in an invisible storage area called the Windows Clipboard. 

9. Now use the Start menu, go to the Programs button, and choose Accessories. Launch the Paint program (alternatively, click the Start button and type Paint in the Search box). Use the Edit menu to paste into the document window. You should see your desktop image!

10. Minimize the Paint document window. Select the Windows Explorer window showing your I drive contents again. This time hold the Alt key down while you press the PrintScreen key.

11. Restore the Paint window. From the File menu, choose New. You will be prompted whether you want to save the “Untitled” file; say no. Use Paste again to deposit the Clipboard contents into the Paint document. This time, you should see only the My Computer window, not the entire desktop. 

12. Now go back to Paint.  Use the File menu and go to Save As to save your file as a file window_screenshot.JPG in the My Personal Stuff folder on your I drive. To do this, 

a. Click the Browse Folders button at the bottom of the Save As window if the Computer icon is not showing in the Favorite Links list.  

b. Click the Computer icon link.  

c. Double click on your I drive.  

d. Double click on your “My Personal Stuff” folder.

e. Now, using the Save as type: menu, choose the JPEG image file format. Note that you do not have to include the .JPG file extension in the File name: window – the extension is automatically added by Windows, based on your choice of file type.

13. Once you have a screenshot in the Windows Clipboard, you can also paste it anywhere (not just in Paint).  Try pasting the screenshot right here by first moving your cursor to the line below and pasting:

[insert window screenshot here]

14. Please remember how to make, save, and insert a screenshot of a particular folder or of your entire desktop. You will need this technique to demonstrate your skills when you take the lab quiz on this unit!
Another Vista “upgrade”
15. So now we know what the PrintScreen button does.  That mystery is solved.  Vista provides a cool “Snipping Tool” that is much like the PrintScreen and Paint rolled into one.   Go back to the Windows Explorer window showing the contents of your I drive.  And let’s say we want an image of JUST the CSCI 1100 folder.  Well…

a. Click the Start button

b. Go to All Programs -> Accessories -> Snipping Tool OR just type in Snip in the Search box.
c. The screen goes a hazy white.  Now use your mouse and draw a selection box around the CSCI 1100 folder.  (If a window is covering up your Windows Explorer window, close the snipping program and try it again).

d. Once you are through selecting the area you want to “snip”, it comes up in a window allowing you to save it.  Don’t save it.  Go to Edit, then Copy.  To paste the image of the folder below, select the text in brackets, hold down the RIGHT mouse button, and select Paste:

[insert folder snippet here]

16. Now we want to move the window_screenshot.JPG file from the My Personal Stuff folder to your CSCI 1100 folder, where it belongs. There are two ways to do this, and we will try them both. 

17. First, let’s try the drag-and-drop method. Use the Windows Logo + E shortcut to open up two Windows Explorer windows.  Navigate to the My Personal Stuff folder in one window and the CSCI 1100 folder in the other window.  Resize these two windows so that they are side-by-side.  Now you can drag the window_screenshot.JPG file from My Personal Stuff into CSCI 1100.

18. Now let’s try the menu method. This one doesn’t require having two windows open, but it doesn’t hurt. Go to the CSCI 1100 window. Click on window_screenshot.JPG.  From the Organize menu, choose Cut. Now go to My Personal Stuff. From the Organize menu, choose Paste.

19. Here are two variations on the menu method:

a. Instead of using the Organize menu, use the keyboard shortcuts Ctrl-X for “cut” and Ctrl-V for “paste.”

b. Instead of using the keys, right-click on the icons and choose “Cut” and “Paste.”

20. When we use a program frequently, it is useful to have a desktop shortcut. First let’s make sure you’re not using the “Classic Start Menu” look.  Right click on the Start button then go to Properties.  Make sure “Start Menu” is selected and click OK.   Press the Start button and choose any program icon you see on the left side of the menu, such as Microsoft Office Word 2007, and drag and drop this program icon to the Desktop. Presto! You have a desktop shortcut.

21. How about customizing the Start menu itself? Can do!  Click on the Start button and choose any item on the left side of the menu (such as Microsoft Word again). Right-click on the item and choose Remove from This List. 

22. Keyboard Shortcuts: although we usually use the mouse to command Windows, it’s also possible to do many commands using only the keyboard. This is faster, and can be a lifesaver if your mouse fails!

23. Tap the ALT keyboard key once and then examine the menus at the top:[image: image6.png]Weekl_WindowsExercise.doc [Compatibility Mode]
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24. Note that one letter of each menu is indicated in boxes. This indicates the keyboard shortcut! To open the File menu, hold down the Alt key and press F. This will open up a shortened version of the File menu. Use the up and down arrows to navigate the menu items. To exit the File menu without choosing any menu items, press Alt again.

25. Now press Alt-W to open up the View menu. You will see the View menu items with more letter boxes surrounding indicating menu choices. Press the Tab key, which gives you another way to navigate through the menu. 
26. Press Shift-Tab to move up the menu.  Press Esc to close the menu.

27. See if you can search this Word document for the word “Internet” without using the mouse at all! Hint: use the Home and then the Find menu. The Tab key moves to the next input box, and the Return key chooses the button you are on.

Some clever tricks and shortcuts
If you can’t get any of these shortcuts working, ask your TA to help you.
The “Show Desktop” shortcut 

28. Sometimes your Desktop is cluttered with too many open windows.  Find the Windows Logo key next to the shift bar. Hold this key down and tap the D key once. All of your windows are minimized at once!  (Pressing Windows + D again causes them to all be active again).

Moving the Taskbar

29. Right-click any empty area of the Taskbar and make sure the item “Lock the Taskbar” is not checked. Now select the taskbar and drag it to the top or left side of the screen. Move the Taskbar back to the bottom of the screen. Now right-click again and click “Lock the Taskbar.” You will no longer be able to move the Taskbar.

Stop a runaway application using the Task Manager.

30. Launch Microsoft Excel (Start -> All Programs -> Microsoft Office -> Excel or click Start and search for Excel). When you press 3 specific keys together (you’ll find out which 3 in a second), you’ll get a pop up window allowing you access to several nifty Windows Security features.  We’ll be looking for the Start Task Manager button.  So press CTRL + ALT + Delete and click the Start Task Manager button. Click the Applications tab, select Excel, and press the End Task button. Excel will disappear. Normally you will close Excel by clicking the “X” at the top right of the Excel window; use this “emergency” method only when the system has locked up and will not respond to the normal mouse controls.

31. While you have Task Manager open, click on the Processes window.  Here you will see the many invisible programs that make up Windows.  The “CPU” column shows what percent of CPU usage is being consumed by each process. Normally the System Idle process, which runs when there is nothing else to do, uses most of the CPU.  If your computer is running slowly, this display will show which process is hogging the CPU. Often the offending process is a virus, worm, or spyware process. You can stop the offending process, which should speed up your computer. Warning: ending Windows systems tasks on your home computer can destabilize your system. If you don't know what the process you just nuked was doing, it would be safer to just reboot.

More Vista Coolness
The Windows Logo + Tab shortcut

32. First, check your taskbar to see if you have at least 3 windows open (if not, open a few Internet Explorer browser windows to up the number of open windows to 3).  Three windows is not a magic number, it just makes this shortcut cooler to see.

33. Now let’s say you want to quickly switch between this window and another open window.  Simply press and hold down the Windows Logo key, and tap the Tab keyboard button.  As you hold down the Windows Logo key, each time you tap the Tab button, another window is brought to the front.  For example, hold down the Windows Logo and tap the Tab key three times.  This is a convenient way to switch between windows while also getting a good view of what’s in the window.
The Alt + Tab shortcut
34. To get a less visually stimulating version of the previous shortcut, instead of the Windows Logo key, press and hold the Alt key.  As you hold down the Alt key, tap the Tab keyboard button.  See which window surfaces when you press and hold the Alt key and tap the Tab key three times.
Window preview
35. Forgot what the content of a window is?  Another way to get a preview is to take your mouse and hover over one of the open windows on the taskbar.  A preview window pops up with a tiny view of the contents of the window.
More Shortcuts

36. Go to http://www.google.com and search with the keywords: Windows Vista Keyboard Shortcuts.
37. Click the first link, “Windows Vista Help: Keyboard shortcuts”.

38. Click the “Microsoft keyboard shortcuts” link in the middle of the page.

39. Some of these shortcuts we have already gone over, but some we haven’t.  Try each shortcut in the list to see the effect.  (Some keyboard shortcuts will bring up a Restrictions error box saying you do not have permission to do such an operation.  If you get this box, click OK and move on to the next shortcut.)
Changing shortcut icons
40. On your desktop you should see a Log Off Vista shortcut with a drab icon.  Let’s change this icon.  
41. Right click on the icon.

42. Click Properties.

43. Click the “Change Icon…” button.

44. A warning box pops up saying the specific file the shortcut points to contains no icons.  Click OK.

45. It will bring up a new box with a bunch of icons located in a dll file on your computer.  

46. Scroll to the very end of this list and you should see a computer screen with a checkmark on it that looks like [image: image7.png]


.  Select this icon and click OK.
47. Yeah, that’s pretty good, for now.  (
Download the Internet Exercise instructions as we did before by following these download instructions:
1. Open up Internet Explorer 

2. Go to http://www.cs.uga.edu/~rwr/cs1100.html
3. Click on the Laboratories link at the bottom of the page.
4. On the new page, click on the Internet Exercise link, then click SAVE
5. A “Save As” window should pop up

6. If the folders are not viewable on the left, click the “Browse Folders” down list arrow at the bottom of the window

7. Click the “Computer” link on the left hand side of the window

8. Double click your I drive.

9. Click the Save button.

10. After the file saves to your I drive, click the Open button.

1. Start button


2. Quick Launch toolbar


3. Taskbar


4. Sidebar


5. Gadgets (in the sidebar)











