CSCI 1100

Introduction to Excel

Part I:  basic formatting, formula, and charts.

1. Download and open the excel_example1.xls  file from the http://www.cs.uga.edu/~rwr/CS1100/labs.html
2. Select the Sheet1 tab on the bottom if it is not already open.

3. From the File menu ([image: image55.png]S e R R A=
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), choose Save As. Make sure that your file is saved in your I: drive or My Documents folder. As you work through the exercises below, save your work every few minutes.

4. [image: image1.png]


This worksheet totals up a customer receipt for Fred's Casual Grocery. (Fred is too cheap to buy a cash register.) Let's customize this sheet to your own name. Click on the words “Fred's Casual Groceries.” Notice that the heading for Column A is highlighted orange at the top, and so is the heading for Row 2 on the left side. The rectangular area that contains “Fred's Casual Grocery,” is called a cell. Notice that the cell address, A2, shows up in the address box near the top left of the sheet.

5. The cell contents, “Fred's Casual Grocery,” shows up in the formula bar near the top of the page. Click here and replace Fred's name with your own [image: image21.png]Range_lookup s a logical valus: to find the closest match n the first column (sarted in
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(unless your name happens to be 'Fred'). As you begin to change the cell contents, an X and a check mark will appear. Try clicking on the X – this will undo your changes and restore the original cell contents. 

6. Return to the formula bar and change 'Fred' to your own name. This time click the check mark. This will commit the changes and return your mouse pointer to cell A2. You can also commit a change by hitting the return key. Important: when you edit a cell, be sure to either click the check mark or press the return key when you are done. 
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Now let’s explore the Excel toolbars. Click the View tab at the top of your screen. You will see a long list of tool buttons. In the Show/Hide group, note that Gridlines, Formula Bar, and Headings are turned on. Try clicking off each of these items and turning each item back on.

8. Click on cell A1, “CSCI 1100.”  Click the Home tab [image: image2.png]


and use the Font group to change this header to 16 point, Comic Sans MS font. Note that the small down-pointing arrows [image: image3.png]


 indicate drop down boxes for changing the selected font and point size.
9. Now find the Bold, Italic, and Underline buttons. [image: image4.png]]



Change the text in cell A1 to italic underlined text.

10. Find the Font Color button,[image: image5.png]


near the right end of the Font group. Notice the little down-pointing arrow, which indicates a drop down box. Click on the arrow to open the color palette. Choose a red color for cell A1.

11. Use the Font tools to change cell A2 to 12 point green Courier font, boldfaced.

12. Remember the Format Paintbrush from our Word exercises? The same tool is available in Excel’s Home menu, in the Clipboard group.[image: image6.png]


 Let's copy the formatting from cell A1 to cell A14, the grand total of the order. First click in cell A1 to select it. Now find the Format Paintbrush tool. If you run your mouse slowly over the toolbars starting from the Printer tool, you will see the tool tips show up and tell you what each tool does.

13. When you find the Format Paintbrush, click it. You have now copied the formatting from cell A1. Click on cell A14 to copy the formatting to that cell.

14. Although Excel is primarily a calculation tool, it is important to provide proper labeling so that we can read and understand our work. In row 4, enter some labels for the columns below. First click in cell A4 and type “Item”. Press the Tab key to move sideways to cell B4. Type “Unit Price” here. Tab over to enter “Quantity” in cell C4 and “Extended Price” in cell D4. (This is a standard accounting term meaning the total cost of a quantity of similar items).
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Now we would like to format all of these four cells. Click inside cell A4 and drag your mouse to the right, until you have selected cells A4, B4, C4, and D4. Then release the mouse. These four cells form a range, one of the most important concepts in Excel. Hint: important concepts might show up on the lab quiz and/or the in-class test!

16. The range you have selected is named A4:D4 in Excel parlance. Find the toolbar button in the Alignment group to center the text. Then boldface the range and color it red. Note that each formatting change applies simultaneously to all the cells in the selected range.
17. In the Font group you will see the Border tool.[image: image7.png]


 Find a border style with a solid bottom border and apply it to the four cells you have selected.

18. [image: image25.png]


Notice that column D is not wide enough to hold the label in cell D4. With your mouse, grab the little crease between the column D header and the column E header at the top. Your mouse pointer should change to a special cross-shaped cursor. [image: image8.png]


Now you can drag and drop to widen column D so that the label has room to display.

19. Now let's do some calculation. The extended price in cell D5 should be the product of the unit price in cell B5 and the quantity in cell C5. This requires an Excel formula, and you create this as follows. Click in cell D5 and type the equals sign “=”. Click in cell B5 and note that the formula bar now says “=B5. Press the “*” key (shift + 8) – this represents multiplication in Excel. Click cell C5 to add C5 to the formula. [image: image9.png]


Finish by clicking the check mark. You should now see “2.49” in cell D5.

20. Just for practice, use the same technique to enter the formula in cell D6. The formula result should be 2.29.

21. We could continue down the column, but this gets boring and is error-prone. One of Excel's most powerful features is its ability to copy formulas. Select cell D6, and notice that a small square “handle” appears at the bottom right of the cell. [image: image26.png]¥ Ciiia)



Grab the “handle” and drag it down, covering the range down to D11. When you release the mouse, the formula has been copied to the entire range.

22. Click in cell D7 and examine the formula bar – it says “=B7*C7”. Click in cell D8 and the formula says “=B8*C8”, which is the correct formula for 16 packs of Ramen noodles. Excel has 'intelligently' altered the formulas to adapt to the changing context.

23. Now it is time to find the total of all the Extended Price column. Click in cell D12. We could compose a formula, but Excel has a special feature. Click the Formulas tab and find the Σ button. This Greek letter, “sigma,” is the mathematical symbol for “Sum”.[image: image27.png]Original data type
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 When you click the Sum button, Excel will automatically attempt to guess the numbers you wish to add up. In this case, Excel will correctly draw a line around all the numbers in column D. Since this is what we want, click the green check to accept Excel's guess. The answer should be 23.21.
24. Carefully examine the formula in the formula bar: =SUM(D5:D11). Recall that D5:D11 is Excel notation for the range of cells from D5 through D11. The parentheses around this range indicate that SUM is a function – a mathematical process that transforms inputs into a single output. In this case the inputs are the six individual values, and the function's output is the sum. In general, a function can have any number of inputs, but always produces a single output.
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The numbers in columns B and D represent currency, and would look better if we formatted them correctly. Use your mouse to select cells B5 through B11 (click in B5 and drag down, then release – note the difference between selecting and using the fill handle). Click the Home tab.  See the big drop-down box at the top of the Number group (see the image to the right)? Use that box to select Accounting style. You will see the dollar signs lined up on the left hand of each cell.

26. Now select cells D5 through D14. As we did previously, change the format, however this time select the Currency format.
27. OK, now it is time to add the sales tax on our groceries. To do this we need the sales tax rate, which is not yet on the sheet. The tax rate is an important part of the model, and needs to be displayed and labeled up above the columns of grocery prices. Unfortunately, we did not leave room for this. That's OK, because we can make room!

Click in the row label 4 at the left side of the sheet. This will select the entire row 4. Drag down until you have selected rows 4 and 5, then release. Still in the Home tab, click the Insert button in the Cells group.[image: image30.png]Avera




. Because you selected two rows, two new rows will appear. Notice that this changes all cell addresses below, but the formulas in column D have all been modified to adjust to the new cell addresses.

28. Now enter the text “Sales Tax Rate” in cell A4 and 7% in cell B4. To highlight this important information, select these two cells. Use [image: image31.png]- | $ - % 9| |%0 % Conditional Format
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the Border tool to surround them with a solid border. Use the Fill color tool [image: image10.png]


to fill in the area with a light yellow background.

29. Click in cell D15. The tax amount should be the product of the subtotal in cell D14 and the tax rate in cell B4. Enter an Excel formula to do this calculation (remember that the formula must start with an equals sign, use cell references instead of values, i.e. D14 instead of “23.21”, and the “*” character represents multiplication). The sales tax in cell D15 should equal $1.62.  If you can’t get the exact formula, ask your TA for help.  It’s crucial to understand and apply Excel formulas correctly.  You will see the difference in the next step…
30. It's important that you always use cell references in Excel formulas instead of copying numbers by hand. To see this, change the tax rate in cell B4 to 5%. The tax should change to $1.16, tracking the change in tax rate. Use the Undo tool [image: image11.png]


to restore the tax rate to 7%. Now click in cell D15 and change the formula to =D14*7%. You will still get the right answer, $1.62. But change the tax rate in cell B4 to 5% again, and the value in D15 will no longer track it. In other words, copying numbers by hand leads to errors when you change your numbers later on. Go back and change both B4 and D15 to their correct values.

31. In cell D16, we need a formula for the total bill, which is the subtotal plus sales tax. Click in D16 and find the Autosum button [image: image12.png]X AutoSum



, which is in the top right part of the Home tab as well as in the Formulas tab. Click this button.
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 Uh-oh! Excel makes the wrong guess as to which cells you wanted to add. Drag with your mouse to select the correct cells D14 and D15, then click the check mark. The total bill should be $24.83.

33. Now let's try calculating the sales tax for each item. In cell E6, put a label Sales Tax. Use the Format Paintbrush to copy the formatting from cell D6 to cell E6, so E6 looks like the other cells in that row.

34. In cell E7, put a formula for the sales tax on the first item. This will be the tax rate from cell B4 times the extended price in cell D7. The result should be $0.17.

35. Remember how we copied the formulas in column D? Let's try that trick again. Select cell E7. Grab the 'fill handle' and drag down to cover cells E8 through E13. Release the mouse to copy the formulas. Ouch! The results are clearly wrong.

36. To see what happened, click in cell E8 and examine the formula in the formula bar. You will see that the extended price in D8 has been multiplied by B5, not B4. When we copied the formula from E7, we wanted D7 changed to D8, but we did not want B4 changed to B5. Click the Undo button to remove the bad formulas.

37. Fortunately there is a way to tell Excel not to change an address when a formula is copied. Go back to cell E7 and change the formula there to =$B$4*D7. The dollar signs create an absolute address or absolute cell reference. Note that the formula value has not changed.

38. Now grab the fill handle again and copy the formula from cell E7 down through row 13. This time, the results will be correct. Click in cell E8 and examine the formula bar. You will see that this time, Excel did not change the address B4 when you copied the formula down.

39. Click in cell E15 and use the Sum tool [image: image13.png]


to add up all the individual item sales tax values in column E.  The value should agree with the sales tax value in cell D15.

40.  Now suppose you'd like a graphical representation of this grocery list. (They don't provide this at Kroger, do they?) A good tool for this purpose is the pie chart, which will show how your grocery dollar is divided among your various food items. Start by selecting the range D7:D13, which contains the cost of all the items in our grocery basket. 
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Choose the Insert tab and find the Charts group. You will be able to select from several different varieties of pie charts; for this example, select the 3-D Pie.
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 The result is colorful, but not yet especially useful! The little colored dots “1”, “2”, etc. are called the legend of the chart. Since they are not helping us, let’s remove them. Note the label “Chart tools” at the top of your window. This means Excel is now giving you a whole set of tabs for charts. Click the Layout tab and in the Labels group, find the Legend tool. Turn the legend off by choosing Legend:None.
43. We still need to label the pie slices. Click the Design tab.  In the Data group, you will find the “Select Data” button.  Click the Select Data button.  In the right side of the window that pops up, you will see “Horizontal (Category) Axis Labels”.  Here is where we tell Excel that our values have labels, but they’re in Column A.  Select the Edit button on the Horizontal (Category) Axis Labels side of the window.  A small window pops up.  With your mouse, select the range A7:A13 from your Excel sheet, then click OK, then OK one more time.  Hmm, since we turned [image: image35.png]More Data Label Optians,



off the Legend, nothing is showing up on our Pie Chart.  In the Layout tab, click the Data Labels tool. At the bottom of the list, select More Data Options.
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In the Options dialog box, uncheck everything, then check the Category Name and Best Fit, then click Reset Label Text. Then select OK.  The Category Names are taken from the first column of your table, and Excel will do a good job of formatting the labels to look good.

Choose the Chart Title tool and pick Above Chart. Excel provides a default title text “Chart Title.” Select this text and type over it the new chart title, “Today’s Grocery Bill.”
Using your mouse, adjust the size of the chart until you like the look. It is easy to copy a chart like this into a Word document or a PowerPoint presentation.

44. The worksheet tab at the bottom of the sheet says “Sheet 1”, which is not very informative. To change this to something more helpful, click on the worksheet tab with the right mouse button. As you know, clicking with the right button says “I am a computer guru and can be trusted with the advanced functions that terrify ordinary users.” Choose Rename, and type “Casual Grocery” to replace “Sheet 1.”

Part II: Functions and data manipulation.

1. Click on the second worksheet, “Sheet 2”. Rename this sheet as “Cycling Mileage.”

2. This sheet records the bicycle miles ridden by members of the Civic Cycling Club on their last few outings. The blank cells represent days on which a particular member did not ride with the CCC.

Reformat cell A1 as 16 point red Comic Sans MS font, italicized. Reformat cell A2 as 12 point blue Arial font, boldfaced.

3. We would like to make the columns narrower so that we can see all the columns at once. Use your mouse to select the top column headers B through K. [image: image38.png]4 Sales Tax Rate 7%]



In the Home tab, find the Cells group and the Format tool (see image at left). Use the Format tool to set the column width to 8. This makes all the columns visible, but unfortunately the labels in row 4 have all been replaced by hash marks “####”. This symbol means that the value is too wide to be displayed in the column. Bummer!

4. Press the Undo button to restore the original column width. Fortunately, we have a trick to fit the dates into a narrower space. Select the dates in cells B4 through H4. In the Alignment group, select the orientation tool ([image: image14.png]


) and select Format Cell Alignment at the bottom of the list. In the Alignment tab, grab the end of the “Text----“ pointer and “dial” it to the orientation you like (choose -60 degrees). Click OK to accept the orientation.
5. You should now see that the dates are slanted down, taking up less space. Using the Format tool, reduce the column width of columns B through K to 8. This time, all the dates should display correctly.

6. [image: image39.png]


Now we would like to center the title “Excursion date” above all the dates. Select cells B3 through H3. From the Home tab, find the Alignment group. Use the Merge and Center tool to center the heading over all the dates.
7. Now change the label “Excursion Date” to red boldfaced text. Note that the label is still entered in cell B3, even though it is displayed elsewhere! You must first click on B3 before changing the format.

8. [image: image40.png]


Next, let’s compute the total mileage for each cyclist. Click in cell I5 and use the Sum tool [image: image15.png]


. Note that because of the blank cell D5, Excel makes an incorrect guess about the cells you wish to sum. You must help Excel by selecting the correct range of cells to sum, which is B5 through H5.  Then click the green check mark to confirm the formula.
9. We could do this again for each cyclist, but it is simpler to copy the formula down to cells I6 through I11. Go ahead and do this now. Reminder: click in cell I5 and grab the “fill handle” at the lower-right corner.
10. [image: image41.png]Extended Price



Next we will compute the average miles ridden per day for each cyclist. This is another example of an Excel function. Think of functions as tools prepared for you to quickly accomplish common tasks. Like presets on a radio dial, Excel functions “remember” how to carry out calculations such as averaging numbers. [image: image16.png]Clipboard & Font 5| Aignment
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11. Click in cell J5 and then click the insert function tool next to the formula bar (see image above). You will be presented with a search box, a drop down list of function categories, and some recently used functions. From the “Categories” box, select Statistical. Click on AVERAGE and click the OK button.

12.  You should now see a wizard box that is helping you set up the [image: image42.png]


inputs to your AVERAGE function. The wizard appears to know what it is doing! But look at the formula result, defined as more than 120. A glance at the table of values shows that Fred Small never rode more than 92 miles per day. He could not possibly have averaged 120 miles per day! What gives? 

13. [image: image43.png]


Look closely at the function arguments range selector. This is where Excel attempts to guess the numbers you want to average. Excel has guessed that you want to average the stack of numbers to the left of the formula cell, cells B5 through I5. This looks reasonable enough, until you realize that cell I5 contains the total mileage for all the excursions, 423 miles. Adding this into the average is what jacks up the result to an unreasonable 120 miles per ride.
14. Fix this problem by using the range selector  [image: image17.png]


 to select the correct range of cells, which includes up to H5 but not I5. Reminder: click the range selector, then select the cells, then click the range selector again, then click OK.  The correct average value should be 70.5 miles per day. 

15. What about the blank space in cell D5? The Excel AVERAGE function ignores missing values. To see this, fill in cell D5 with a zero. You will see the Fred’s average mileage go down. Press the Undo key to restore the blank space.
16. Should we count missing values as zeroes or not? That’s a policy decision and depends on the application. In the case of bicycle riders, the club would likely want to count only the average mileage on rides in which the rider actually participated. But for pop quiz grades in a class, the instructor would likely count missing grades as zeroes.

17.  Copy the average formula down to the rest of column J using the fill handle. Notice that the different riders have different numbers of decimal places in their averages. To make the output more aesthetic, select the averages in column J and in the Home tab, use the Format Numbers dropdown box in the Numbers group. Choose the Number item, and change all the averages to Number format with two decimal places.
18. Let’s expand the names in column A to a friendlier format, such as “Fred Small” instead of “Small, Fred.” To do this we can break the single column into two columns. First, we need to create an extra column.
Click on the column header for column B, which should select the entire column. Choose the Home tab and find the Cells group. Here, select [image: image44.png]4 [rem Unit Price___Quantity ___Extended price
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Insert Sheet Column. A new column will appear and the other columns are moved to the right. As always, all formulas are rewritten to adjust to the new addresses.
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 Now select the names in cells A5:A11 and choose the Data tab. In the Data Tools group, find the Text to Columns tool.[image: image46.png]/| Ruler V| Formula Bar
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 Looking at the Original Data Type selections, you should see that our data matches the “Delimited” type, with commas separating each field of the data. The fields in our data are last name and first name. Go ahead and click Next. In the second screen[image: image47.png]X  f| Darfs Casua
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, you are asked to choose the delimiter character used. Since our fields are separated by commas, check the Comma box and uncheck the Tab box.

20. Click Finish. The comma-delimited names should now be expanded into two columns.
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Unfortunately, the first and last names are in the wrong order! To switch them, select cells A5:A11. Choose the Home tab, and click the down list arrow for Insert and select Insert Cells.  Choose shift cells right and click OK. Now you have some empty room to work with. Select the first names in C5:C11 and press Ctrl-X. Click in cell A5 and press Ctrl-V. Finally, select C5:C11 and click the Delete tool (Home tab->Cells group). Choose Shift cells left. You should now have the names in first name, last name order.
22. The label in cell C16 is scrunched, so let’s move it to cell B16 where there is more room. Click on cell C16 and carefully move your mouse pointer to the edge of the selected cell. When the cursor changes to the crossed arrows [image: image18.png]


, grab the edge and drag it over to cell B16. When you release the mouse, the cell contents will be in cell B16.

23. Columns A and B are wider than they need to be. Move your mouse to the line of column headers at the top. Position your cursor on the crease between columns B and C. When the cursor changes to this shape [image: image19.png]


, press the mouse and narrow column B until it is just wide enough to hold the names. Do the same with Column A. Note that the long label in cell A14 flops over several cells, but that’s OK.
24. Let’s rank the cyclists by their total mileage. Select the entire table A4:K11. Still in the Home tab, choose Sort and Filter, then Custom Sort. Choose to sort by column J, in order of largest to smallest. You should see Keith Lester at the top, followed by Fred Small and Susan Hoplite.
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Let’s add ranks to the list. Enter 1 in cell L5, since Keith Lester is in first place. We could enter the rest of the rankings by hand, but it’s always more fun to let the computer do it. Select L5:L11. Still in the Home tab, find the Fill tool in the Editing group (see image at left).  Choose Series. Excel will suggest a step value of 1, which works for us. Click OK to let Excel fill in the rankings.
26. Now we would like a column chart of the various cyclists’ average mileage. Can you remember how to do it?

a. Select cells K5:K11, containing the cyclists’ average mileages;

b. Go to the Insert tab and select Column in the Chart group. Pick the first option for a 3-D column chart.
c. You should now see the Chart tabs. Pick Layout and use the Legend tool to turn off the legend. (“Series 1” does not tell us a lot! On the test, you’ll be marked off if you turn in a chart with a useless and distracting legend like this one.)

d. Using the Data Labels tool, select the More Data Labels Options… button and set the data labels to “Category Name”.  
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Go to the Design tab and click Select Data from the Data group.[image: image53.png]Calibri
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  Find Horizontal (Category) Axis Labels and click Edit. Now you can choose cells A5:A11, which contain the first names of our cyclists. Go back to the Layout tab and set the Chart Title to “Average Miles per Day.”

27. The chart appears on your worksheet surrounded by sizing handles. Grab one of the handles on the side and stretch the chart out until all of the first names are visible on the X axis.
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We can do some formatting on the resulting chart. For example, you can change the boring gray background color. Just right-click on the background and pick a different color using the Fill tool. If you are using a 3-D chart, you can format the ‘walls’ and ‘floor’ of the background as different colors.
29. Notice that each of the cyclists averaged more than 50 miles per day. Right-click on the vertical axis and choose Format axis. In the Axis Options section, set the minimum value to 50 (see image at right). You will see that the differences among the bar heights are emphasized (some would say exaggerated!)

30. Next we will show you a very powerful Excel tool called table lookup. Note that cells C17:D23 contain a table of cycling categories that members can enter by racking up miles. For example, riding at least 100 miles makes you a ‘slacker’, 200 make you a ‘newbie’, and so on. To emphasize this table, select C17:D23. Surround this range with a solid border and fill it [image: image20.png]


 with a yellow background. Reminder: these tools are on the Home tab, in the Font group. You may need to widen column D a bit.
31. With C17:D23 still selected, click on the name box, at the left of the formula bar. Type in “Categories” in the top box.  Now we can use “Categories” as an alias for the table of categories. (This is not absolutely necessary for what follows, but it helps make the formulas more readable. Besides, it’s a good Excel technique to know about!)

32. OK, now we will use the Categories table to look up the category of each rider in our table. Click in cell M5 and press the function select tool. From the Lookup & Reference category, select VLOOKUP. 

33. You will see a rather intimidating wizard, but here’s the deal. We want to look up Keith Lester’s total mileage, 511 miles, in the Categories table. From the second column of this table we will extract his category, Flier. So here’s how we fill in the wizard:

a. The value to be looked up is in cell J5. This goes in the first blank.

b. The table array where we will do the lookup is what we named Categories. So we can just type the name Categories into the second blank.

c. The value we will extract from the Categories table is in the second column. So 2 goes in the third blank.

d. Click in the fourth blank, Range_lookup. This is the most abstract of the parameters, but the wizard gives us some help.  We know we won’t be able to find an exact match, since 511 is not found in the table. So we enter TRUE into the fourth blank to find the closest match. Note that in this case, we are required to have the table sorted in ascending order.
e. Click OK. The value “Flier” should appear in cell M5. Yowsers! 

34. Using the magic of Excel copying, copy this formula down to the rest of the cells in column M. Note that because Categories is a named range, it is automatically treated as an absolute cell reference.

That’s it! You have now practiced your basic Excel techniques. Go on to the exercise where you predict your CSCI 1100 course grade (also available on WebCT). And don’t forget to put Excel on your resume!

