CSCI 1100

Excel function practice

1. Prerequisites: This exercise assumes a basic familiarity with Excel formulas and functions. You should be OK if you have completed the Introduction to Excel lab exercise on Dr. Robinson’s website.

2. Start by downloading the Excel Function Practice Workbook (available from Dr. Robinson’s website). Please save this to the I: drive right away so you will know where it is later. Open the workbook and let's begin.

Time and date functions: 
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Make sure you are in Sheet1 of the Excel workbook.  Click in cell B4. The label says we should put in the current date. Click the function wizard tool. [image: image21.png]


 Select the Date and Time function category, and pick the TODAY function (see image at right for help). You will see that this function does not need any arguments. Click OK to complete the function. 

4. Yikes! The display changes to “#####.” This just means that column B is too narrow to display the full value. Widen column B until you can see the full value.

5. For a more precise determination of the current date and time, click in cell B5 and use the NOW function. You may need to widen column B some more.
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Click in cell C4 and use the MONTH function to determine the current month. Note that this function requires an input called Serial_number. The wizard explains what Serial number is (see image below/right). Practice using the range select tool to select the date (you will want to use the date in cell B4 for this input). The answer should be the current month as a number from 1 to 12 (1=January, 2=February, and so forth).
7. Click in cell D4 and find a function from the list to get the day of the month (1 to 31) for the current date. 
8. In cell E4, find a function for the day of the week. The wizard for this function is a bit confusing. By clicking in the top box you will see that serial_number is the actual date of the week, while return_type just gives different codes for representing the result. Use the return type of 1 for now.
9. Copy these three formulas down to row 5. You should get the same values for each, since these properties do not depend on the time of day.

10. Now, find functions to fill out the range F5:H5.  Since these values are dependent upon the time, the serial_number input will need to be a cell with the time value in it (i.e. cell B5). These values should be different, because they do depend on the time of day.

11. Hey, the value in B5 is out of date by now! To recalculate, press the F9 function key. Not only should the current time redisplay, but the minutes and seconds should be recalculated as well. Actually, it is unusual for an Excel function to change when you recalculate it.

Mathematical Functions:
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Click in cell B8 and enter a function to find the value of the notorious number PI. You will find this function in the Math & Trig category.

13. [image: image10.png]Data
Goal seck.

Formula Audting » | &

window  Help




In the Home tab, in the Number group, use the increase decimal button (see right) to increase the number of decimal places in this result. How many decimal places can you get? This gives you an idea of how accurately Excel can compute numbers.

14. Suppose that for some bizarre reason we wanted to know the square root of PI. Your enrollment in this course is that reason! Click in cell B9 and look up the SQRT function. Notice that this one takes an input which will be the PI cell. (The answer should be about 1.77)
15. In cell B10, use the ROUND function to round the value in B9 to the nearest integer (read the input instructions to figure out how to round to the nearest integer). The result should be 2.

16. In cell B11, use the INT function to round the value in B9 to the next lowest integer. The result should be 1 this time.

Statistical functions:
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On the home tab, in the Alignment group, use the Merge & Center button to merge and center the range C12:H12. 
18. Click in cell B15. In our previous exercise we used the sum tool to calculate the sum of a range of numbers. This time, use the SUM function, which is in the Math & Trig function category, and sum assignment scores. You will need to provide an Excel range as the input argument – don’t forget the Range Select tool [image: image2.png]
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In cell B16, use the COUNT function, which is in the Statistical category, to get the number of non-blank assignment grades.

20. In cell B17, use the COUNTIF function to get the number of assignment scores over 100. For the criteria input, enter “>100”, including the quotes! 
21. In cell B18, use the COUNTIF function to get the number of assignment scores under 80.

22. Use the MAX and MIN functions to fill in the answers in B19 and B20.  For the MAX/MIN functions, in the Number 1 input, you can put the entire range you want to find the max or min for.
23. In B21, use the Average function to average the assignment scores.

24. Recall that the average of a collection of numbers is the sum of the numbers divided by how many there are. Use this information to construct a formula in cell B22 that does not include any function calls.  Instead, construct a formula that divides cell B15 by the total number of assignments (6). The value will be different from cell B21! Can you explain this? Which value is more likely to be correct?

25. Replace the missing grade in cell D14 with a zero. Now the two values for the average should agree.

26. The standard deviation is a statistical measure of dispersion, that is, how spread out they are. Joe College has some pretty scattered grades. In cell B23, use the STDDEV function to compute the standard deviation of the assignment grades.

27. In cells B27 and B28, compute the average and standard deviation for Jane Johnson's grades. You should find that her standard deviation is smaller, because her grades are more closely grouped.

28. [image: image13.png]Joe College’s assn grades
Assn 1 Assn2 Assn3 Assnd Assn5 Assn6
79/ 102 9 105, B3



Statistical theory tells us that about 2/3 of the values should fall within one standard deviation of the mean. To check this, compute the values in B29 and B30.  Use cell references and the values in cells B27 and B28 for the formulas in B29 and B30.
29. How many of Jane's six scores should fall between these two numbers?  Let's test this out by using Conditional Formatting on the assignment scores. First, select Jane’s six assignment grades.  Next, on the Home tab, in the Styles group, click the arrow next to Conditional Formatting, go to Highlight Cells Rules, then select Between. 

30. Follow the example shown below using the “between” condition (you can use the range select options to select B29 and B30 or you can type them in as shown). You can select a different coloring format if you’d like.  You will see that there are four assignment values within one standard deviation of the mean. [image: image14.png]



Text functions: 
31. Examine the names in cells B33:C37. In column D, use the PROPER function (from the Text category) to translate the first names to correct capitalization for proper names, then do the same for column E for the last names (Proper First Names will go in column D, Proper Last Names will go in column E).  **Note that once you have created one instance of this function, you can copy it to all the other cells using the Fill Handle.

32. In column F, use the CONCAT function to create full name representations of all the names, such as “Jane Smith.”  Text1 input to this function will contain the proper first name cell, Text2 input will be the a space within quotes (like “ ”), and Text3 will be the proper last name cell.  If you left out the space in between the first and last name cell inputs, well, you’d get a format like the login name to the 1100 lab computers, which we don’t want.
33. Similarly, in column G, use the CONCAT function to create representations of all the names, using the format “Smith, Jane.”  
Logical functions

34. Click on the Sheet 2 worksheet tab for more interesting examples. Dan’s Discount Duds for Dapper Dressers was doing most of its business on weekends, so Dan decided to offer deeper discounts on weekdays to lure in some more customers.
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Start by clicking on cell B7. Use a function to calculate today’s date (we did this in the first section of this exercise – hint: it’s not the DATE function). Grab the fill handle on the bottom right of the cell and drag to copy this formula out to column Z.

36. Unfortunately all of the cells contain the same value! What we want is for the date to increase by one each time. With the range B7:Z7 still selected, in the Home tab, in the Editing group, select the Fill button and then Series (see right). The wizard should be pre-set with a step value of 1. Click OK to accept these values. The range B7:Z7 should now represent consecutive dates.

37.  Now click in cell B8 and use the WEEKDAY function to calculate the day of the week. Of course you will want the serial number to be the date in cell B7. For this example, you can use return type 1. You’ll see why this works in the next section.

38. Copy this formula to the rest of B8:Z8. Examine the results – what value corresponds to a Friday? You will need this is in the next part.

39. Now click in cell B9. Here is where we will use a Logical function to actually compute the discount. Insert the IF function from the Logical function category. Examine the worksheet – you will see that there are three parts to the calculation:
a. A true-or-false condition;

b. The value to use if the condition is true;

c. The value to use if the condition is false. [image: image16.png]Insert Function (0|
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40. Fill out the function wizard as shown in the example here. Note that the top box contains an algebra expression which does not represent a number, but instead evaluates to a true or false value. Your job is to replace the “???” with a number that will make the condition be true on Sundays through Thursdays and false on Fridays and Saturdays. (If you are uncertain just make a guess of 5, then click OK. You can always fix it!)

41. Copy this function to the range B9:Z9.  From the home tab, format these values as percents with zero decimal places.

42. Examine the result of the function and see if it really does give the 20% discount only on Sundays through Thursdays. If it doesn’t work, go back to fix the formula in B9. Note that you will need to re-copy to the whole range after you have fixed the function.

A science example using math functions:
43. Coffee drinkers tend to like their beverage hot. A study done at the University of California, Davis showed that the average coffee drinker prefers his or her cup of Java at 160 degrees F, which is above the oral pain threshold. 
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We have set up the model in the next section to reflect the cooling process. The key values inside the yellow box are called parameters, and they will stay constant as we run the model. The column headings “minutes after serving” and “coffee temperature” are called variables, and they will change as the model runs.

45. Select cells A24 through A54. Use the Fill Series technique to change this range to a series of time values from zero to 30 minutes.
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Click in cell B24 and enter the following formula: =B20+(B19-B20)*EXP(B21*A24). The result of this formula should be 170. The EXP function is called an exponential function and is used heavily in science.  Rather than puzzle out what this means, in the Formulas tab, in the Formula Auditing group, click the Trace Precedents menu item. You should see a set of blue arrows shooting into cell B24. These show that the coffee temperature at any time depends on the initial coffee temperature, the room temperature, and the “Cooling coefficient,” which measures how fast the coffee cools off. Notice that the temperature at time zero is the same as the initial temperature. Think about this for a second until you are convinced that any other result would be wrong. If you confused about this, stop for a moment to consult a TA.
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From Formula Auditing, click Remove Arrows. Now grab the fill handle at the bottom right of B24 and copy the formula down to B25. Yikes! The coffee has cooled down to room temperature in only one minute!
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Obviously something is wrong here. Look in the formula bar and compare the cell references with the values in the parameter box. You will notice that the formula no longer references the initial coffee temperature, for example. This is not right.

49. In general, when we copy a formula, all references to the parameters should stay constant. This is because parameters, by definition, are supposed to remain unchanged. Go back to cell B24 and put dollar signs on cell references to the parameter block. For example, the reference to the initial coffee temperature should read $B$19 or just B$19 (because Excel won’t change the column numbers anyway, since you are copying down.) Be sure to NOT put dollar signs on the references to column A. These are variables, which are supposed to change.

50. Now copy the formula from B24 to B25. The coffee has cooled slightly, to 158.6920437 degrees (if you do not get this result, ask your TA for help.  You may not have applied Absolute Cell References correctly).
51. Copy the formula down to B26:B54. After half an hour, the coffee is barely above room temperature, or “stone cold” in common parlance.
52. This is a ridiculous degree of accuracy and looks messy. Choose cells B24 through B54 and format them with two decimal places.

53. I can accept my coffee going stone cold after 30 minutes, but I’d like it still hot after 10 minutes. One way I could do this is to serve the coffee hotter in the first place. Click on cell B34. Use Data tab->What if analysis -> Goal Seek to set up the following problem as seen at right.  Replace “???” with the cell address of the Initial Coffee temperature parameter. You can either type in the value or use the range select box [image: image3.png]


 to grab it from the worksheet. Click OK to run the analysis.

54. Yikes! The coffee is way above the boiling point of water!
 Hit the Undo button [image: image4.png]


  to return to the original scenario while we think this over.
55. Maybe I should try using an insulated mug, which would reduce the cooling coefficient in cell B21. Click in cell B34 again.  Use Goal Seek again to determine what cooling coefficient is needed so that my coffee is still at 160 degrees ten minutes after serving. (You should get a result of about -0.0105.)
Financial functions
56. On the right side of Sheet2 we have a ‘typical’ college student loan worksheet. The parameters are in cells E18:G19. Format this range similarly to the parameter box for the coffee problem. You might need to experiment with the buttons in the Font group on the Home tab.
57. In cells E21:G21 are the column headers for our variables. Format these like the variable headers for the coffee problem.

58. In cells E22 and E23 we have started a list of possible numbers of monthly payments. Normally this will be a multiple of 12. Select E22:E29 and choose Home tab->Editing group->Fill button->Series. Note that Excel detects the pattern in the first two cells and suggests a step value of 12. Click OK to accept the suggestion.

59. Click in cell G22.  Insert the PMT function from the Financial category, which calculates a monthly payment. You will need only to choose the first three arguments shown below.  Read the directions on the inputs carefully to figure out which variable or parameter cell goes into each box. (By convention, the ‘present value’ is supposed to be negative, so we have formatted it this way in the worksheet.). Click OK to accept the calculation. [image: image5.png]Function Arguments
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60. Yikes! You will be paying over $3,000 per month to get your student loan paid off over 3 years. But this is actually the wrong answer. Click the function select tool again and look at the definition of the Rate argument: 
61. Aha! Go back to the function wizard and use G19/12 as the interest rate per period. This reduces the payment to a less staggering $1,235 per month – but still a lot.

62. Let’s see if a longer payment period will be less painful. Before copying, click on G22 again and in the function, make all cell references to the parameter block into absolute addresses (with the dollar signs) – ask your TA for help if you need it.

63. Now copy the formula down to get the result of paying the loan off on a longer time scale. As we would expect, the payment is smaller for longer time periods.

64. Select G22:G29.  Go to the Insert tab, and in the Charts group, see if you can make a chart that looks like the one shown below. Use the Chart Tools toolbar to select the data for the X-Axis (36, 48, … from cells E22:E29) – this is in the  Design tab, Select Data; and from the Layout tab, turn off the legend, and add appropriate Axis and Chart titles. 
65. In cells H22:H29, calculate a formula for the total amount you pay under each scenario by multiplying the monthly payment by the number of payments. This will involve copying a formula. Note that the answer is always greater than $40,000. Why?
66. In cells I22:I29, calculate the total amount of interest that you pay (the total amount of interest would be the difference between the amount you borrowed and the amount you pay). This will involve composing a formula with an absolute cell reference to the amount borrowed parameter, and also keep in mind we had to put the loan amount in as negative to keep the PMT function happy, so you’ll need to convert it back to positive in your formula.

67. Finished! Good show! Keep your solution and these handouts handy when you go through the practice exams. You won’t be allowed to use these notes on the actual lab quiz, though.
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� H.S. Lee, M. O'Mahony (2002) �At What Temperatures Do Consumers Like to Drink Coffee?: Mixing Methods �Journal of Food Science 67 (7), 2774–2777. �doi:10.1111/j.1365-2621.2002.tb08814.x


� Water boils at 212 defrees F.  In the notorious McDonald’s coffee case, a restaurant served coffee at up to 180 degrees F, hot enough to cause third-degree burns in 2 to 7 seconds.





